FC2ブログ

サラリーマンのすらすらIT日記

IT関連を中心とした日々を綴ります。
--/--/--

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
2012/02/21

RubyでFirebirdにアクセスしたいが...

RubyでFirebirdにアクセスしようと考えています。FireRubyやfbといった接続用ツールがあるのですが、どれ一つうまくいきません。何がうまくいかないかというと、インストール時にエラーが出るのです。

Building native extensions. This could take a while...
ERROR: Error installing fb:
ERROR: Failed to build gem native extension.


このエラーメッセージが出て困ったという人は結構いるようで、Webで検索するとたくさんヒットします。しかしそこに示された対策方法を取っても解決しないというのが、今の状況です。

Webにはいい情報はないし...と思っていると思い出したのが、「Firebird徹底入門」という本。この本には様々な言語からFirebirdを使う方法を紹介されています。筆頭に出てくるのがDelphi。そりゃそうでしょうね、最も親和性が高いので。以下.NET、C++、Ruby、PHP、Java、ODBCと主要な言語はほとんど紹介されています。Rubyの節には、gem install fbでインストールする、との記述が。これは私がやって上述のエラーを出した時のコマンドです。あまり参考にはなりませんでした。

もう半ばあきらめムードです。またその気になったらチャレンジしてみます。

スポンサーサイト

コメント

コメントの投稿

  • URL
  • コメント
  • パスワード
  • 秘密
  • 管理者にだけ表示を許可する

トラックバック

トラックバックURL:http://sookibizviz.blog81.fc2.com/tb.php/1112-04a3ab57

■  カレンダー

06 | 2019/07 | 08
- 1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31 - - -

■  プロフィール

sookibizviz

Author:sookibizviz
仕事の内容やソフトの紹介を交えながら、日々の悪戦苦闘を綴っていきます。

■  最新記事

■  最新コメント

■  最新トラックバック

■  月別アーカイブ

■  カテゴリ

未分類 (64)
BizViz (24)
IT (1119)
計量 (76)
環境 (26)
数学 (181)
ニュース (46)
本 (187)
音楽 (113)
囲碁 (5)
将棋 (26)
ブログ (14)
日記 (19)

■  FC2カウンター

■  検索フォーム

■  RSSリンクの表示

■  QRコード

QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。