サラリーマンのすらすらIT日記

IT関連を中心とした日々を綴ります。
--/--/--

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
2013/06/06

Python3が使えるGUIプログラミング

今からPythonをやろうとした時、悩んでしまうのがVer2.xにするか、Ver3.xにするかという点。普通に考えると新しいバージョンの方を取ってVer3.x(最近Ver3.3がリリースされましたね)ということになるのですが、開発ツールでVer3.xに対応していないものが結構あるのです。GUIに限定しても、wxWidgetsが32bitのみ対応らしい(知らなかった!)ので困ったものですが、こちらによるとPyQtがVer3.x対応で、しかも64bit対応。見た目もよさそうなのですが、「今さらQt?」というのが第一印象。Qtって結構昔からあったと記憶しています(Wikipediaによると、1992年が初版)。

そうするとwxPythonはやめて、Qtにしようかと考えています。上記サイトによるとPyQtのバージョンにあったバージョンのPython(上記サイトではVer3.2.3と書かれている)をインストールする必要があります。MyPCにはまだPython2.7だけでPython3は入っていないので、よく調べてから合ったバージョンのPythonをインストールする必要があります。

スポンサーサイト

コメント

コメントの投稿

  • URL
  • コメント
  • パスワード
  • 秘密
  • 管理者にだけ表示を許可する

トラックバック

トラックバックURL:http://sookibizviz.blog81.fc2.com/tb.php/1583-dff2888c

■  カレンダー

08 | 2017/09 | 10
- - - - - 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30

■  プロフィール

sookibizviz

Author:sookibizviz
仕事の内容やソフトの紹介を交えながら、日々の悪戦苦闘を綴っていきます。

■  最新記事

■  最新コメント

■  最新トラックバック

■  月別アーカイブ

■  カテゴリ

未分類 (64)
BizViz (24)
IT (1119)
計量 (76)
環境 (26)
数学 (181)
ニュース (46)
本 (187)
音楽 (113)
囲碁 (5)
将棋 (26)
ブログ (14)
日記 (19)

■  FC2カウンター

■  検索フォーム

■  RSSリンクの表示

■  QRコード

QRコード
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。